Apalis TK1 Won't Run TEZI

I have an Apalis TK1 V1.2A module plugged into my Ixora V1.1A carrier board.

I’ve prepared both a USB mass storage device and also a microSD card however I cannot get the Toradex Easy Installer to boot from either media.

As far as I can tell, both media have the correct files:

ls mmc 1:1
Apalis TK1 # ls mmc 1:1
            recovery/
   724480   apalis-tk1.img
      540   boot-tezi.scr
     1371   image.json
      878   recovery-linux.sh
       42   recovery-windows.bat
 34865224   tezi.itb
     2997   tezi.png
   707765   u-boot-dtb-tegra.bin
       18   wrapup.sh

9 file(s), 1 dir(s)

and

ls usb 0:1
Apalis TK1 # ls usb 0:1
            recovery/
   724480   apalis-tk1.img
      540   boot-tezi.scr
     1371   image.json
      878   recovery-linux.sh
       42   recovery-windows.bat
 34865224   tezi.itb
     2997   tezi.png
   707765   u-boot-dtb-tegra.bin
       18   wrapup.sh

9 file(s), 1 dir(s)

but all that happens is as follows:

Apalis TK1 # run distro_bootcmd
switch to partitions #0, OK
mmc1 is current device
Scanning mmc 1:1...
MMC: no card present
switch to partitions #0, OK
mmc0(part 0) is current device
Scanning mmc 0:1...

USB device 0:
    Device 0: Vendor: VendorCo Rev: 2.00 Prod: ProductCode
            Type: Removable Hard Disk
            Capacity: 7680.0 MB = 7.5 GB (15728640 x 512)
... is now current device
Scanning usb 0:1...
e1000: no NVM
BOOTP broadcast 1
BOOTP broadcast 2
BOOTP broadcast 3
DHCP client bound to address 192.168.0.198 (1003 ms)
*** Warning: no boot file name; using 'C0A800C6.img'
Using e1000#0 device
TFTP from server 192.168.0.4; our IP address is 192.168.0.198
Filename 'C0A800C6.img'.
Load address: 0x81000000
Loading: *
TFTP error: 'File not found' (1)
Not retrying...
missing environment variable: pxeuuid
missing environment variable: bootfile
Retrieving file: pxelinux.cfg/01-00-14-2d-63-0b-34

I’ve tried resetting the environment variables to defaults using env default -a && saveenv but this doesn’t seem to make a difference.

Any clues as to what I’m missing, please?

For reference, the TEZI image being used is the latest Toradex stable release for the Apalis TK1.

Turns out that I’m an idiot… there was no boot.scr file present, just a boot-tezi.scr file. All works now!