Apalis-tk1 oe-core build fails do_prepare_recipe_sysroot refs/heads/LinuxImage3.0

Hi,

Recipe fails with this message. Checked config twice read instructions over and over. Build finish fine with Colibri-imx6. What’s wrong?

Looks like a bad path. How to fix?

Thanks

ERROR: xf86-input-evdev-2_2.10.6-r0 do_prepare_recipe_sysroot: Error executing a python function in exec_python_func() autogenerated:

The stack trace of python calls that resulted in this exception/failure was:
File: 'exec_python_func() autogenerated', lineno: 2, function: 
     0001:
 *** 0002:extend_recipe_sysroot(d)
     0003:
File: '/home/INO/user0545/code/oe-core/build/../layers/openembedded-core/meta/classes/staging.bbclass', lineno: 553, function: extend_recipe_sysroot
     0549:                    dest = newmanifest[l]
     0550:                    if l.endswith("/"):
     0551:                        staging_copydir(l, targetdir, dest, seendirs)
     0552:                        continue
 *** 0553:                    staging_copyfile(l, targetdir, dest, postinsts, seendirs)
     0554:
     0555:    bb.note("Installed into sysroot: %s" % str(msg_adding))
     0556:    bb.note("Skipping as already exists in sysroot: %s" % str(msg_exists))
     0557:
File: '/home/INO/user0545/code/oe-core/build/../layers/openembedded-core/meta/classes/staging.bbclass', lineno: 151, function: staging_copyfile
     0147:        os.symlink(linkto, dest)
     0148:        #bb.warn(c)
     0149:    else:
     0150:        try:
 *** 0151:            os.link(c, dest)
     0152:        except OSError as err:
     0153:            if err.errno == errno.EXDEV:
     0154:                bb.utils.copyfile(c, dest)
     0155:            else:
Exception: FileExistsError: [Errno 17] File exists: '/home/INO/user0545/code/oe-core/build/tmp/sysroots-components/apalis_tk1/mesa/sysroot-providers/virtual_libgles1' -> '/home/INO/user0545/code/oe-core/build/tmp/work/armv7at2hf-neon-tdx-linux-gnueabi/xf86-input-evdev/2_2.10.6-r0/recipe-sysroot/sysroot-providers/virtual_libgles1'

ERROR: xf86-input-evdev-2_2.10.6-r0 do_prepare_recipe_sysroot: Function failed: extend_recipe_sysroot
ERROR: Logfile of failure stored in: /home/INO/user0545/code/oe-core/build/tmp/work/armv7at2hf-neon-tdx-linux-gnueabi/xf86-input-evdev/2_2.10.6-r0/temp/log.do_prepare_recipe_sysroot.13076
ERROR: Task (/home/INO/user0545/code/oe-core/build/../layers/openembedded-core/meta/recipes-graphics/xorg-driver/xf86-input-evdev_2.10.6.bb:do_prepare_recipe_sysroot) failed with exit code '1'

Hi @Franck

Could you provide the version of the Software and Hardware of your module?
Have done any changes to local.conf or any other files? If yes, can you share these changes?

Which Linux distribution and which version are using on your host?

Best regards,
Jaski