Apalis T30 hangs with CPU1 Shutdown Message

Hello,

I’m testing a couple Apalis boards by rebooting them by SSH every other minute using a cronjob.
Once in a while a board gets stuck with a “CPU1 Shutdown” message displayed on the screen. The only way to wake up the board again is by manually pushing the reset button.

This is a huge problem for us, because our software uses a similar procedure out in the field.

Image Version Apalis_T30_LinuxImageV2.6_20160331
Hardware Version Apalis 1.1A

Any ideas what’s going on here?

It happened again. Here’s the output from the serial port:

The Angstrom Distribution apalis-t30 ttyS0

Angstrom v2015.12 - Kernel 3.1.10-V2.6b2+g34c5824

Apalis_T30_LinuxImageV2.6_20160331

apalis-t30 login: [   17.302537] CPU1: Booted secondary processor
[   17.311107] Switched to NOHz mode on CPU #1
[   17.401889] CPU2: Booted secondary processor
[   17.411164] Switched to NOHz mode on CPU #2
[   17.442430] igb 0000:01:00.0: enp1s0: igb: enp1s0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX/TX
[   17.453000] ADDRCONF(NETDEV_CHANGE): enp1s0: link becomes ready
[   19.392874] CPU1: shutdown
[   21.394218] CPU2: shutdown
[  OK  ] Stopped Hostname Service.
[  OK  ] Removed slice system-getty.slice.
         Stopping Disk Manager (legacy version)...
[  OK  ] Stopped Forward Password Requests to Wall Directory Watch.
         Stopping Network Time Synchronization...
[  OK  ] Stopped target Sockets.
[  OK  ] Stopped Dispatch Password Requests to Console Directory Watch.
         Stopping Load/Save Random Seed...
[  OK  ] Stopped target Local File Systems.
         Unmounting /media/mmcblk0p1...
         Unmounting /run/user/0...
         Stopping Load/Save Screen Backlight...ss of backlight:pwm-backlight...
         Stopping OpenSSH Per-Connection Daemon (192.168.11.55:51450)...
         Stopping Session c2 of user root.
         Unmounting /var/volatile...
         Stopping Session c1 of user root.
         Stopping WPA supplicant...
[  OK  ] Stopped target Graphical Interface.
         Stopping LXDE Display Manager...
[  OK  ] Stopped target Multi-User System.
[   46.416411] CPU1: Booted secondary processor
         Stopping Network Name Resolution...
[  OK  ] Stopped target Login Prompts.
         Stopping Serial Getty on ttyS0...
     [   46.431112] Switched to NOHz mode on CPU #1
    Stopping Avahi mDNS/DNS-SD Stack...
         Stopping Authorization Manager...
         Starting Store Sound Card State...
[  OK  ] Stopped target Sound Card.
[   46.491568] CPU2: Booted secondary processor
[   46.501102] Switched to NOHz mode on CPU #2
[  OK  ] Stopped Network Time Synchroni[   46.592782] CPU3: Booted secondary processor
zation.
[   46.601108] Switched to NOHz mode on CPU #3
[  OK  ] Stopped WPA supplicant.
[  OK  ] Stopped Disk Manager (legacy version).
[  OK  ] Stopped Network Name Resolution.
[  OK  ] Stopped LXDE Display Manager.
[  OK  ] Stopped Avahi mDNS/DNS-SD Stack.
[  OK  ] Stopped Serial Getty on ttyS0.
[  OK  ] Stopped Authorization Manager.
[  OK  ] Stopped OpenSSH Per-Connection Daemon (192.168.11.55:51450).
[  OK  ] Stopped Load/Save Random Seed.
[  OK  ] Unmounted /media/mmcblk0p1.
[   48.592398] CPU1: shutdown

Are you absolutely sure that “CPU1 Shutdown” message really has anything to do with the freeze/hang you are seeing? That message is printed quite often during regular DVFS operation and may just be the last message being printed well before the freeze/hang condition. That said you may easily disable CPU hot-plugging as follows:

root@apalis-t30:~# systemctl disable nv-conf

Other than that it would be interesting to know at what exact stage you are experiencing the freeze/hang (e.g. during boot-up or rather shutdown) plus a capture of the serial debug console output of the last successful plus the failing run. Of course any information concerning your exact environment (e.g. displays and/or displays connected etc.) could be helpful too.

No, I’m not sure. I’m trying to run the test and this time capture the output over serial.
It doesn’t happen very often, so it might take a couple days until I’ll catch it.

Sure. We are really not aware of any such issue.