Apalis T30 - Enable USB1,USB2 as host mode by default

I am trying to set USB1, and USB2 as host by default. Normally, USB2 works, so I am trying to enable USB1 as well.

If I just add USBEHCI1 and USBFN registry changes, then USB1 turns on and works, but USB2 stops working. If I then add the USBEHCI2 key as below, then both USB ports stop working.

SodimmPen=112                 ;mxm274
PenPol=1   ;active high

SodimmPen=54                 ;mxm84
PenPol=1   ;active high


Dear @kswain
This is a known software limitation, all USB host instances share a common power enable (MXM3_84 by default).
As a workaround, I suggest you set the SodimmPen key for one of the USB host ports (e.g. 112), and control the other power enable pin directly from your software.

You can set pin 84 to high already in the bootloader: Modify the settings in the section gpio.bootconf using the ConfigBlockEditor or the bootloader command line:
Add the following string to the already existing default settings:

[apalispin_84] altfn=-1 dir=out lvl=1

Please get back to us if this workaround is not sufficient for you.
Regards, Andy

Understood. Is there a way I could set GPIO84 to default to output high on powerup, perhaps using the config block editor? If so, what parameters would work for this?

Dear @kswain
Yes, setting it in the configblock is possible. I extended my answer above to describe the procedure.
Regards, Andy