Apalis module won't boot in Evaluation Board

Hi,

Some months ago I purchased an Apalis iMX6Q 2GB module and an Evaluation Board, with the aim of performing some basic testing on the Evaluation Board before incorporating the module into my custom carrier board. I’ve only this morning actually removed the module and board from their packaging and set everything up. I’ve applied a 12V source to the X15 connector (per the datasheet), but on pressing the on/off button (SW9), I only receive the 3V3 LED (3V3_SW, 5V_SW and 12V_SW stay off) and the RESET_MOCI LED is permanently on. Using the RESET switch has no impact.

From the research I’ve done, the RESET_MOCI LED is asserted if the module isn’t able to boot, and the 3V3_SW, 5V_SW and 12V_SW rails won’t be activated until the relevant MOCI enable output is asserted by the module. Given that the module should have come with an OS pre-installed, is this likely to be a dead/defective module?

Any input would be greatly appreciated; I had planned on testing the custom carrier board with this module over the coming days, so a dead module would be somewhat disastrous at this stage!

I’ve now tried entering recovery mode using this guide, but I’m not getting any response whatsoever from the module. The Evaluation Board is recognised by my host machine (Windows 7), and I can successfully establish a serial communication via USB, but no serial data is ever presented from the module. When shorting the required pads on the module on start up, the RESET_MOCI red LED remains lit, so there’s no change from the initial condition.

Hi @jars121,

Is your power supply also providing enough current? 12V 2A is recommended for the Apalis Evaluation board.

Also X15 is the terminal block power supply, can you confirm that the polarity of the power supply is inserted correctly?

Best Regards,
Jeremias

Hi @jeremias.tx, yes I have tried 2 power supplies; one is 12V @ 2A rated, which has a barrel jack and was connected to X17, the other is 12V @ 6A rated which was connected to X15. I’ve measured the voltage at X15 with a multimeter and confirmed correct polarity.

A somewhat similar issue to yours can be found here: https://www.toradex.com/community/questions/34187/the-reset-moci-led-is-always-on.html

Perhaps you could perform measurements on the rails specified on that post and compare your findings. Any off voltages could signify damaged hardware.

Best Regards,
Jeremias

Thanks Jeremias. I’ve just been through all the test points, and all points are measuring 0V with the below exceptions:

  1. +V1.2_VDDSOC = 0.05V
  2. +V3.0_RTC = 1.01V
  3. PWR_ONOFF = 0.05V
  4. +5V_USB = 3.14V
  5. +V3.3_MXM = 3.27V

Given the findings on the linked post, and the fact that almost all my test points are 0V, I suspect there may well be a hardware issue at play.

Yes this seems to be a hardware damage related issue. Contacting the Toradex sales office where you got the module for a replacement would probably be the simplest solution.

Best Regards,
Jeremias