Apalis IMX8 no video output


I have an Apalis IMX8 Quad Plus 2GB V1.1C with an Ixora V1.2A carrier board. I am using Yocto, building the tdx-reference-minimal image.

I am trying to get the 10" LVDS Toradex V1.0 screen to work.

I followed the instructions at First Steps with Capacitive Touch Display 10.1 Inch LVDS | Toradex Developer Center.

But I get no video on the screen.

I even tried to hook up an HDMI monitor (switching back to the hdmi overlay), but I see nothing here as well. I have also tried the tdx-reference-mulitmedia image, same results.

There is nothing displayed on the screen, during U-Boot or in Linux. The only time I have seen video is via HDMI using the easy installer.

Best regards and thanks in advance,

Hello pally,

the tdx-reference-minimal image is a pure console image so no video output ,

Best Regards,


Hi Matthias,

Thanks, that is good to know.

I also tried on the tdx-reference-multimedia image but could not see any HDMI output. Is that also expected?


Hello Did you install it from our feed?
After reboot do you see the consol logs?

Best Matthias Gohlke

I am building the image using Yocto dunfell, Index of /meta-toradex-demos.git (5.2.0).

Console log after reboot is shown here.

The repo manifest is retrieved via:

repo init -u https://git.toradex.com/toradex-manifest.git -b refs/tags/5.2.0 -m tdxref/default.xml

Hi @pally !

If you take a look at the Reference Images for Yocto Project 5 of the article that you pointed, you will see that it redirects you to the Device Tree Overlays (Linux) | Toradex Developer Center article.

In that article, you’ll see that you need to enable:

  • apalis-imx8_lvds_overlay.dtbo
    • to enable the LVDS interface
  • display-lt170410_overlay.dtbo
    • specific for the Capacitive LVDS 10" from Toradex
  • apalis-imx8_atmel-mxt_overlay.dtbo
    • for the touch screen to work

The /boot/overlays.txt will be like this:

fdt_overlays=apalis-imx8_lvds_overlay.dtbo display-lt170410_overlay.dtbo

This should help you to get output from the Capacitive LVDS 10" display.

Best regards,

Hi Henrique!

Thanks for the link. I have tried to enable those overlays as indicated in the article you mentioned. I do not see any output on the LVDS screen.

And with the hdmi overlay, I see no output on the HDMI screen.


Hi, @pally!

As you build your own image, can you confirm that you made no modifications to the default recipes?

Also, can you check if the overlay files are inside the /boot/overlay directory?

Best regards,

Hi Henrique,

I am using the default recipes, with the mender layers that I need for OTA. The overlay files are present in /uboot/overlays.


I have downloaded the tdx-reference-multimedia-image file from the Toradex JFrog artifactory, and I get video output on the LVDS. Now I would like to figure out why it doesn’t work when I build the image myself using Yocto.

I see some errors when I run my own build that I do not see in the image downloaded from the artifactory.

[    1.669447] imx-drm display-subsystem: parent device of /bus@57240000/ldb@572410e0/lvds-channel@0 is not available

weston service also seems to fail for me:

root@apalis-imx8:/uboot/overlays# cat /var/log/weston.log 
Date: 2018-03-09 UTC
[16:35:23.067] weston 9.0.0
               Bug reports to: https://gitlab.freedesktop.org/wayland/weston/issues/
               Build: lf-5.10.35-2.0.0-rc2+
[16:35:23.067] Command line: /usr/bin/weston --modules=xwayland.so --log=/var/log/weston.log
[16:35:23.067] OS: Linux, 5.4.115-5.3.0-devel+git.dbdbcabf0f98, #1 SMP PREEMPT Tue Jul 6 08:47:10 UTC 2021, aarch64
[16:35:23.068] Using config file '/etc/xdg/weston/weston.ini'
[16:35:23.069] Output repaint window is 7 ms maximum.
[16:35:23.070] Loading module '/usr/lib/libweston-9/drm-backend.so'
[16:35:23.081] initializing drm backend
[16:35:23.081] logind: failed to get session seat
[16:35:23.081] logind: cannot setup systemd-logind helper (-61), using legacy fallback
[16:35:23.083] no drm device found
[16:35:23.083] fatal: failed to create compositor backend

And I cannot use fbset:

root@apalis-imx8:~# fbset
fbset: can't open '/dev/fb0': No such file or directory

Hi @pally,
The error output you mention could be related to a missing piece in the device tree. With the default device tree, the ldb@572410e0 is “disabled” as is the lvds-channel@0 that is its child (you can see the file at arch/arm64/boot/dts/freescale/imx8qm-ss-lvds.dtsi).
Looking at the first log output you sent, I cannot see the output from u-boot saying that the overlays where activated. You should see something like this when the overlays are properly setup (please keep in mind that this is a different module but the output should be similar in your case):

Found U-Boot script /boot.scr
5752 bytes read in 14 ms (400.4 KiB/s)
## Executing script at 83200000
Loading DeviceTree: imx8qxp-apalis-eval.dtb
127257 bytes read in 22 ms (5.5 MiB/s)
149 bytes read in 10 ms (13.7 KiB/s)
Applying Overlay: apalis-imx8x_dsihdmi_overlay.dtbo
1663 bytes read in 24 ms (67.4 KiB/s)
Applying Overlay: apalis-imx8x_parallel-rgb_overlay.dtbo
1378 bytes read in 26 ms (51.8 KiB/s)
Applying Overlay: display-lt161010_overlay.dtbo
863 bytes read in 26 ms (32.2 KiB/s)
Applying Overlay: apalis-imx8x_ad7879_overlay.dtbo
403 bytes read in 24 ms (15.6 KiB/s)
10259747 bytes read in 319 ms (30.7 MiB/s)
Uncompressed size: 24267264 = 0x1724A00
Bootargs: root=PARTUUID=58ecc002-02 ro rootwait video=imxdpufb5:off video=imxdpufb6:off video=imxdpufb7:off
## Flattened Device Tree blob at 83100000
   Booting using the fdt blob at 0x83100000
   Loading Device Tree to 00000000fd620000, end 00000000fd662fff ... OK

If the overlays are being correctly activated and you still cannot get video out, it would be good if you could send us full console logs of both the working setup and the not working one so that we can try to check for differences between them.


Hi Rafael,

Thanks for your analysis. The problem has to do with the boot.scr script, which was changed by the mender layers and does not apply the overlays correctly. I have moved the discussion to the mender community if you want to follow the details. I have a working patch now, which is posted there.


Very good to know! Thank you for the feedback.