Apalis IMX8 ixora GPIO

I want to test GPIO for imx8. I found there are LED4 and LED5 on board Ixora.
the default linux system does not have leds device tree, then I download linux and compile a device tree for Ixora board. then I found

/sys/devices/platform/leds, and led4_red/green led5_red/green.

I run linux command:

echo 0  /sys/devices/platform/leds/leds/LED_4_RED/lightness
echo 1  /sys/devices/platform/leds/leds/LED_4_RED/lightness

but the led does not change, I can not control it.
then I removed leds in device tree, and set pinmuxc for 4 pins of led4/5.
I used gpioset to control these pins, but nothing happened.
I used sysfs, echo 340 > export, I either can not control the pin (480-32*5+20=340)
I have to try another pins, such as pwm1/2/3/4, I configured these pwm pins to gpio, and use gpiomon to monitor these pins. I found only pwm3 is correct, I used 3.3v to trigger this pin, it works, and gpioget is also correct. but another 3pins nothing happens, the read value is zero.
I tried GPIO1/2/3/4, nothing happened.
and I can not find IMX8QM chip’s reference manual, I only found imx8mm and imx8dual/quadxplus’s. can someone show me the download address.link text

I fixed this issue.
I need to use:

&iomuxc {
    gpio {
      pinctrls_led : led_grp {
        pinname  0x41

last time, I do not know I need to add gpio to pinctrl

HI @wen_jian_1973

Pefect that your issue is solved. Thanks for the feedback.