Apalis iMX6 will not boot properly

I am not 100% sure what happened, but I believe some pins on the Ixora Power Out Header (X4) got shorted, and ever since then the board will not boot properly.

On boot-up, the only message sent to serial console is “Industrial temperature grade DDR3 timings.”

I am not able to use the board at all, and when I tried to reset using Toradex Easy Installer, the script returned with an error saying the following:

Could not open device vid=0x1b67 pid=0x4fff

Downloading Toradex Easy Installer failed…

Have you put the module into recovery mode using the HW mechanism as describe here before running the Toradex Easy Installer script?

Yes, that is the method that I used to reset the device using the Easy Installer.

Did you made a OTG connection to your Host?
Is the module shown in recovery mode in your host, if you type lsusb | grep -i free?

Best regards,
Jaski

I made the OTG connection, and my host detects the module. But, I will run the command, and let you know the output.

Hi

We will wait for the output.

I do not know what changed, but the Toradex Easy Installer now says that there is no matching USB device found.

The result of the lsusb | grep -i free returns nothing.

  • Please double check if your module is in recovery mode.

  • Try another USB cable

What is you desktop OS?

I double checked that I am in recovery mode and tried another cable, and it still does not work. I then performed the same steps on a spare board, and everything worked fine. There must be something wrong with the SoM and carrier board.

I am using Ubuntu 16.04.6 LTS.

I also should mention that the particular board that I am having trouble with I configured to boot from SD card on power up to boot a custom OS based on Toradex BSP 4.0.

After making no changes other than plugging the micro USB in and out a few times, the board is now recognized by the computer. The ‘lsusb’ command returns the proper board information and says recovery mode. But still, when I try to use the Toradex Easy Installer, the script returns the same error as shown in the original post.

I assume you followed this article to the minute (e.g. make sure to do a full power-cycle when entering the recovery mode):

https://developer.toradex.com/knowledge-base/imx-recovery-mode#apalis-imx6

Yeah I followed every single step. I even switched the SoM to a module I know was working, and everything worked as it should. I think that when the pins on the X4 header got shorted, something in the SoM changed, causing the board not to boot properly.

HI @aronreman17

Thanks for your input.

Maybe something is damaged on the SoM Hardware. Could you measure the voltages described in this document and share the results.

Thanks and best regards,
Jaski

Attached are all of the measured voltages. The 3.3 V test points seemed a little low. The only other value that may be off is Vref, since I could not find what this value is meant to be.

alt text

HI @aronreman17

Thanks for the sharing the Results. The voltages are OK.

May I ask you which version of Toradex Easy Installer are you using?
Is the hardware version of the working SoM the same as the non-working?

Best regards,
Jaski

I am using Toradex Easy Installer 1.8. And yes, the working and non-working module have the same hardware version.

HI @aronreman17

Your SoM seems to have a Hardware Issue. We apologize that you experience this with our Hardware. Someone from Toradex will contact you by E-Mail and give Instructions how to send the module back to Toradex.

Best regards,
Jaski