Apalis iMX6 Parallel Display Interface (RGB24), Newhaven Display

Hello

I use the Apalis iMX6 Quad Module and I have a problem with the usage of a Newhaven Display. I’ve tried to use it with the RGB24 parallel connector of the Ixora Board. I’m using the generic display adapter provided by Toradex to connect the third party display.

I adapted the Image provided by Toradex. To be more precise i exchanged the filesystem built by openEmbedded framework through a generic Debian filesystem. I’ve already done some additional Kernel configuration. But basically I’m using the Kernel configured by apalis_imx6_defconfig provided by Toradex.
In addition I’m using the Device-Tree imx6q-apalis-ixora-v1.1.dts without any modification.

At first I’ve tried to set the environment variable in u-boot to:

 setenv vidargs 'mxc_hdmi.only_cea=0 video=mxcfb0:dev=lcd,800x480M@60,if=RGB24
 video=mxcfb1:off video=mxcfb2:off video=mxcfb3:off fbmem=32M'

But the display stays black.

Afterwards I’ve tried to add the exact display timings to the lcd driver “fsl,lcd” in the toradex kernel. So I’ve created a new entry;

 {
     /* 800x480 @ 65 Hz , pixel clk @ 33 MHz */ /* 30303 ps*/
     "newhaven1", 65, 800, 480, 30303,
      .left_margin = 128,
      .right_margin = 40,
      .hsync_len = 48,
      .upper_margin = 45,
      .lower_margin = 13,
      .vsync_len = 3,
      .sync = 0,
      .vmode = FB_VMODE_NONINTERLACED,
      .flag = 0,}

After that I compiled the kernel successfully and added it to the image. In the image I changed the environment variable for the display in uEnv.txt to:

 setenv vidargs 'mxc_hdmi.only_cea=0 video=mxcfb0:dev=lcd,newhaven1,if=RGB24
 video=mxcfb1:off video=mxcfb2:off video=mxcfb3:off fbmem=32M'

Then I’ve flashed the board with the Toradex EasyInstaller. When I check the FrameBuffer configuration with fbset I get the timings I’ve added in the driver, but the display doesn’t work. The screen lights up for a short time while booting. Afterwards the display is just black with the backlight on.

Has anyone an idea how to fix this problem?

Here are the exact version of the used tools:

Versions:

Easy Installer
apalis-imx6_toradexeasyinstaller_1.8-20181019

Image
Apalis-iMX6_LXDE-Image_2.8b5.156-20181228

Toolchain
gcc-linaro-6.2.1-2016.11-x86_64_arm-linux-gnueabihf

Kernel 2.8b
toradex_4.9-2.3.x-imx Linux kernel : 4.9.144

Device Tree
imx6q-apalis-ixora-v1.1.dtb (from imx6q-apalis-ixora-v1.1.dts)

UBoot 2.8b
2016.11-toradex

Filesystem
Debian 9.8

Display
NHD-5.0-800480MB-ATXL-CTP
https://www.newhavendisplay.com/nhd50800480mbatxlctp-p-9611.html

Hi @iMX6_user

Could you provide the complete serial boot log in a file and the output of fbset and xrandr?

Thanks and best regards,
Jaski

Hi

Here is the bootlog:
dmesg.txt

The output of fbset is:

mode "800x480-60"
    # D: 33.000 MHz, H: 32.480 kHz, V: 60.038 Hz
    geometry 800 480 800 480 16
    timings 30303 128 40 45 13 48 3
    rgba 5/11,6/5,5/0,0/0
endmode

Frame buffer device information:
    Name        : DISP3 BG - DI1
    Address     : 0x3c100000
    Size        : 768000
    Type        : PACKED PIXELS
    Visual      : TRUECOLOR
    XPanStep    : 1
    YPanStep    : 1
    YWrapStep   : 1
    LineLength  : 1600
    Accelerator : No

The output of xrandr is:
Can’t open display

I had to install x11-utils before.

hi @iMX6_user

Thanks for the dmesg file and the information.

Could you revert your changes in the kernel and apply the changes from the driver to the devicetree file arch/arm/boot/dts/imx6ull-colibri-eval-v3.dtsi and check if this working?

Please read also the following article.

Best regards,
Jaski

Hi @iMX6_user
I have the exact same problem! did you make it?
I have the same LCD from Newheaven connected to Apalis iMX6 via parallel RGB and then as your problem: “The screen lights up for a short time while booting. Afterwards the display is just black” …
could you solve this problem?
any help would be appreciated…