Apalis iMX6 Flashing Linux update failed

I have a new Apalis iMX6 D 512 on an Ixora card, that I’m attempting to reflash with the latest image. I’m new to Linux and may have misinterpreted the instructions. I’ve followed “How to setup environment for Embedded Linux application development” and then “Flashing Embedded Linux to iMX6 Modules”. My host is ubuntu 16.04 LS. Can anyone give me pointers as to what to do next and where I went wrong? I’ve attached the terminal output from the boot. The last line repeats but increments the first number.
The instructions in “Flashing Embedded Linux to iMX6 Modules” are a little less explicit for the newbee so I may have missed something. Here are the commands I ran:
Apalis iMX6 # run setupdate
Apalis iMX6 # run update
power cycle
Apalis iMX6 # run setupdate
Apalis iMX6 # run update_uboot
y to setting fuses.
Apalis iMX6 # run setupdate
Apalis iMX6 # run update_kernel
Apalis iMX6 # run update_fdt

link text

Based on the provided boot log it appears that the system is booting successfully with the latest kernel. Do you have a display connected?

You probably don’t need to go the route of updating the individual components one at a time (ie. run update_uboot, run update_kernel, etc) - in doing so it seems you may have missed updating the rootfs (ie. run update_rootfs.

Typically, run setupdate & run update are sufficient. If the update requires additional migration steps, then it may ask that you reset mid-update back into the latest bootloader to complete the update by executing run setupdate & run migrate.

I do have a display. On a normal boot it shows some of the bootup scripts then goes blank. For uboot it constantly shows the Toradex logo. I tried run update_rootfs on the 232 terminal and got "## Error: “update_rootfs” not defined ".

Ahh yes, sorry, its no longer update_rootfs, but update_3. In any case, I recommend run update/run migrate rather than performing the updates piece-wise in order to avoid missing anything.

What kind of display are you using? You may need to tweak the video settings (ie. vidargs) in the bootloader as described here: http://developer.toradex.com/knowledge-base/display-output-resolution-and-timings-linux

You’ve done it again thanks, problem solved! I’m booting normally to the update and the screen is working–didn’t need to change anything for the screen.
I only did “run update” do you think I need the “run migrate”?