Analog on Apalis T30 WEC2013

I am trying to use the ADC (V2_0bis2868) library on Apalis T30/WEC2013. I’ve thus far successfully got GPIO and PWM working fine.

However, I can not get anything except 0 from the ADC library. I followed the example in ADCLibDemo, and can successfully get the ADC version number (ADCGetLibVersion), the coded type (4) and the MicrovoltsperLSB (805). But a call to ReadADCChannel just gives me 0 for value.

Anything I’m forgetting?

Thanks,
Erik

Which BSP Version are you using currently? The latest lib needs at least image V1.4. You can check the image version using the Update Tool (Start → Programs → ColibriTools → Update Tool ->Version Info).

I’m using V1.4.

I’ve followed the c# example available from the development center very closely… I always get 0 for a returned value.

SPI, PWM, GPIO all seem to work fine.

Channels 0-3 I get 0,

if I read channels 4,5, or 6 I get 4095 for sample=1, 40950 for sample=10.

This to me indicates the library is working, but there is something wrong in the configuration.

Do I need to set the pin a particular way? Is it possible that the 10" capacitive touch screen driver is causing this issue?

Samuel,

That seemed to fix it. Thanks!

As far as I remember the installer for the 10" capacitive touch removes the standard touch driver. In the current touch driver there is an initialization issue. Here is a preliminary release or our libraries that should fix the init issue. Please let us know if this works or not.

I’m working with @embedded_erik.

Are you planning to do a more formal release with this fix? All I see at http://developer.toradex.com/software/windows-embedded-compact/toradex-ce-libraries-and-code-samples is V2.0bis.2868.

Thanks,
Dylan

I have been working to upgrade using the image Toradex BSP 2.0beta4. The problem previously reported by Erik has re-emerged. I tried using Toradex Windows CE Library Package V2.0bis.2868 as well as the preliminary release that @samual.tx supplied in this thread. Neither works successfully with beta4.

Any advice?

Thanks,
Dylan

Oops, I misspelled @samuel.tx.

@dmcreynolds: I quickly did some tests on CE 7 with 2.0 beta 4 on a a eval board with the demo program. I have disabled the touch display driver and everything worked as expected. Can you provide us the code a sample project including the LIB which you have been using, so we can quickly try to reproduce that here.

@samuel.tx: We are using the touch display driver. Wouldn’t the test be run with it enabled?

Thanks,
Dylan

@dmcreynolds: I just tested on 2.0Beta4 WinCE7 Apalis T30. Installed capacitive touch driver, connected capacitive touch display and run ADC demo with latest libraries, everything worked fine as expected. Can you please share a test code along with libs.