After loading Toradex Easy Installer display shows nothing

I have Ixora Carrier Board with Apalis iMX8QM and I tried to use Toradex Easy Installer in order to install Torizon, but for some reason I don’t see anything on my connected display.

Initially there was an installed Torizon, but default password was changed and lost. So I decided to install Torizon again. I chose USB OTG approach, entered recovery mode, and ran recovery-windows.bat. The execution of recovery-windows.bat ended with “Successfully downloaded Toradex Easy Installer”, after that I connected my display via HDMI port, but the display showed nothing. When I connected my display, the board was on, but USB cable from my PC to X9 port was already detached. What did I do wrong?

I also tried previous version of Toradex Easy Installer (2.0b4-20191231), it did not work for me as well.
Moreover I tried to connect over the network, my ixora board was connected via a LAN cable to my router, but in my router I didn’t find any new connected device, at the same time the router’s ethernet port status was active and the RJ45 connector of my ixora board had constant orange indicator on.

The display works well with currently installed Torizon (TorizonCore 4.0.0-dev-20191211+build.36 colibri-imx8), when the OS is loaded I see login/password input. The display is powered via USB port. I powered the display via USB port of my PC and via USB port (X7) of the board, but the display showed nothing in both cases. When I powered my display via X7 and connected the display to my PC, the display worked as expected.

Thanks in advance!

Greetings @AlexeyZ,

First of all can you establish a connection to the device over serial. Just to make sure the Easy Installer tool is indeed starting up properly. If you are seeing output over serial then the issue may be display related.

It appears it has been the case that some HDMI displays may not work well with our Easy Installer tool. If possible could you try a different HDMI display, as the issue may just be with that particular display you are using.

Also have you tried accessing the device display using VNC from your PC? Or is that what you meant by tried to connect over network?

Best Regards,

Hello @jeremias.tx
The problem was with my display. When I connected the board to another display, everything worked fine. Thank you!

Perfect that it works. Thanks for the feedback.