Adding WiFi to Apalis TK1 Eval Board

I am attempting to install an Intel 3160 wireless card on an Apalis TK1, however I have been unable to connect to any networks. The system is able to see the card, and the card is able to see the available networks, but it can’t make connections.

Network manager can see the device, but the menu is grayed out and listed as “device not ready”

Running iwlist scan reports wlan0 Interface doesn't support scanning., but running sudo iw dev wlan0 scan shows the SSIDs in the area.

The BSP version is Apalis-TK1_LXDE-Image_2.8b1.64-20171229 and the system is running Ubuntu 14.04

Here are some command snapshots:

$ dmesg | grep iwl
[    9.759415] iwlwifi 0000:04:00.0: loaded firmware version 17.608620.0 op_mode iwlmvm
[    9.810273] iwlwifi 0000:04:00.0: Detected Intel(R) Dual Band Wireless AC 3160, REV=0x164
[    9.893228] iwlwifi 0000:04:00.0: base HW address: 2c:6e:85:55:75:c1
[   10.003470] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'

and

$ modinfo iwlwifi
filename:       /lib/modules/3.10.40-2.8.1+g877a323/updates/drivers/net/wireless/intel/iwlwifi/iwlwifi.ko
version:        backported from Linux (v4.14-0-gbebc608) using backports v4.14-rc2-1-34-g1d8cc15
license:        GPL
author:         Copyright(c) 2003- 2015 Intel Corporation <linuxwifi@intel.com>
description:    Intel(R) Wireless WiFi driver for Linux
firmware:       iwlwifi-100-5.ucode
firmware:       iwlwifi-1000-5.ucode
firmware:       iwlwifi-135-6.ucode
firmware:       iwlwifi-105-6.ucode
firmware:       iwlwifi-2030-6.ucode
firmware:       iwlwifi-2000-6.ucode
firmware:       iwlwifi-5150-2.ucode
firmware:       iwlwifi-5000-5.ucode
firmware:       iwlwifi-6000g2b-6.ucode
firmware:       iwlwifi-6000g2a-6.ucode
firmware:       iwlwifi-6050-5.ucode
firmware:       iwlwifi-6000-6.ucode
firmware:       iwlwifi-7265D-29.ucode
firmware:       iwlwifi-7265-17.ucode
firmware:       iwlwifi-3168-29.ucode
firmware:       iwlwifi-3160-17.ucode
firmware:       iwlwifi-7260-17.ucode
firmware:       iwlwifi-8265-34.ucode
firmware:       iwlwifi-8000C-34.ucode
firmware:       iwlwifi-9260-th-b0-jf-b0--34.ucode
firmware:       iwlwifi-9260-th-a0-jf-a0--34.ucode
firmware:       iwlwifi-9000-pu-a0-jf-b0--34.ucode
firmware:       iwlwifi-9000-pu-a0-jf-a0--34.ucode
firmware:       iwlwifi-QuQnj-a0-hr-a0--34.ucode
firmware:       iwlwifi-QuQnj-a0-jf-b0--34.ucode
firmware:       iwlwifi-QuQnj-f0-hr-a0--34.ucode
firmware:       iwlwifi-Qu-a0-jf-b0--34.ucode
firmware:       iwlwifi-Qu-a0-hr-a0--34.ucode
srcversion:     9B124ACC35A1F94A98AE124
alias:          pci:v00008086d00002720sv*sd00001080bc*sc*i*
alias:          pci:v00008086d00002720sv*sd00000070bc*sc*i*

Have you tried this - https://developer.toradex.com/knowledge-base/wi-fi-(linux)#manual ?

I have tried those instructions and I get the following error:

$ connmanctl scan wifi
Error /net/connman/technology/wifi: Not supported

Can you share more on the software you’re using? We don’t have sudo and Network Manager in LXDE builds.
iwlist uses an deprecated wireless extensions, we’re only supporting nl80211.

Network manager provides high-level interfaces for configuring network interfaces. It is replaced by Connman when I install that package. I currently have version 1.15 of Connman installed.

Running uname -a gives the following output:

$ uname -a
Linux tegra-ubuntu 3.10.40-2.8.1+g877a323 #1 SMP PREEMPT Fri Dec 29 02:18:05 UTC 2017 armv7l armv7l armv7l GNU/Linux

We are using the rootfs of linux for tegra 21.6

In order to compare these instructions with a standard system, I have reverted my machine to the Linux image provided by Toradex and am using the LM006 USB wifi dongle.

# uname -a
Linux apalis-tk1 3.10.40-2.8.1+g877a323 #1 SMP PREEMPT Fri Dec 29 02:18:05 UTC 2017 armv7l GNU/Linux

# lsusb | grep WLAN
Bus 001 Device 006: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter

This has allowed me to make more progress in the instructions. However, towards the end of the instructions for bringing up the Wi-Fi connection, I have been encountering the following error:

# connmanctl connect wifi_<HASH>_managed_psk
Error /net/connman/service/wifi_<HASH>_managed_psk: Not registered

hi my system is Linux tegra-ubuntu 3.10.40-2.7.5+g22e0897 #1 SMP PREEMPT Thu Nov 30 22:51:24 UTC 2017 armv7l armv7l armv7l GNU/Linux. For me the connection to a network is working fine.

I ended up solving the problem using the steps described in this link: https://wiki.debian.org/WiFi/HowToUse#WPA-PSK_and_WPA2-PSK

Thanks for the information.