Adding EDIMAX N150 for Apalis Imx6

Hi

I am working on an Apalis iMX6 Quad 2GB board and I am unable to connect a wifi dongle to the board.
The wifi dongle is the Edimax N150.

How do I install the driver for the Edimax N150 in the Apalix iMX6 board?

Regards
Jy.Teh

hi @jy.teh

Welcome to the Toradex Community!

Could you provide the version of the hardware and software of your module? Which carrier board are you using?

Did you try the dongle on a regular Bsp Image (for example 2.8b6) and check if the dongle is working? If it is not working, then please share the complete dmesg log in a file?

Thanks and best regards,
Jaski

I am using a Toradex Apalis iMX6 Quad 2GB attached to an Apalix Evaluation Board.

I tried the stable built downloaded from here
https://developer.toradex.com/knowledge-base/flashing-linux-on-imx6-modules#Flashing_from_Scratch

When i tried the latest built i got the following error:
" reading uImage
** Unable to read file uImage **"

Please find the log trace from the start of the board with the stable built.
The dmesg starts from line 592

link text

When i tried the latest built i got the following error: " reading uImage Unable to read file uImage "

Could you stop in U-Boot during booting sequence and do the following command:

env default -a
saveenv

and then reboot the module.

I tried the stable built downloaded from here https://developer.toradex.com/knowledge-base/flashing-linux-on-imx6-modules#Flashing_from_Scratch

As an alternative to this, we recommend you to use the Toradex Easy Installer to install the Image on the module.

Thanks and best regards,
Jaski

Hi Jaski

Please find the logs attached.

The logs are collected with the latest build. (Apalis-iMX6_LXDE-Image 2.8b6.184 20190401)

When i plug the wifi dongle it detect as a bluetooth device, in connmanctl there is no wifi visible.
How do i enable the wifi?

link text

The firmware of your dongle is not included in the regular bsp image, you need to copy this from the host to your module.

Best regards,
Jaski

how do I do this?
Where could i find the firmware for my dongle?

I tried following the how to build the kernel backport here ( https://developer.toradex.com/knowledge-base/kernel-backports-integration)

But still could not get the wifi to work.

Where could i get the firmware for my dongle?

If you insert the dongle in the usb port of your host, then you should see, where the file is located on your host. You can just copy this.

What file type is the firmware for the dongle?

Which location do i copy the firmware in my module

You should look for this file on your host: rtl8723b_fw.bin. This file should be copied to the folder /lib/firmware/rtl_bt/rtl8723b_fw.bin on the module.

i mange to copy over the firmware files of the modules.

Currently the bluetooth part of the dongle is working, but the wifi is still not working.
Once i plug in the dongle, the BT firmware is loaded but nothing is being done for the wifi.

Attached is the log file.
link text

Thanks for this Information.
Could you provide the output of lsusb on the module with Wifi Dongle connected to the module?
Additionally please share the complete dmesg log in a file ( dmesg > dmesg.txt ) after connecting the Wifi Dongle to your host?

lsusb shows the dongle have been connected.

lsusb
Bus 001 Device 004: ID 7392:a611 Edimax Technology Co., Ltd 
Bus 001 Device 003: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 002: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
root@apalis-imx6:~# lsmod
Module                  Size  Used by
rfcomm                 30722  2
bnep                    9738  2
btusb                  27571  0
btrtl                   6040  1 btusb
btbcm                   5404  1 btusb
btintel                 7969  1 btusb
bluetooth             312436  31 btrtl,btintel,bnep,btbcm,rfcomm,btusb
usb_f_rndis            11166  2
u_ether                 8661  1 usb_f_rndis
compat                 76582  4 bluetooth,bnep,rfcomm,btusb
ov5640_camera_mipi_int    21592  0
mxc_v4l2_capture       25556  1 ov5640_camera_mipi_int
ipu_bg_overlay_sdc      5233  1 mxc_v4l2_capture
adv7280_tvin            6681  0
ipu_still               1763  1 mxc_v4l2_capture
max9526_tvin            5870  0
ipu_prp_enc             5763  1 mxc_v4l2_capture
ipu_csi_enc             3417  1 mxc_v4l2_capture
ipu_fg_overlay_sdc      5872  1 mxc_v4l2_capture
v4l2_int_device         1883  4 ov5640_camera_mipi_int,adv7280_tvin,max9526_tvin,mxc_v4l2_capture
libcomposite           34201  10 usb_f_rndis
configfs               23662  3 usb_f_rndis,libcomposite
galcore               366432  4
root@apalis-imx6:~#

please find the log files attached.
There are 3 files : full.txt, dmesg.txt and lsusb.txt
From the logs you could see that I plug in the Edimax Dongle (the one that i would like to use with the board) to the Apalis board and immediately the bluetooth is enable. We could see that some bluetooth files are being called. But there is nothing on the wifi portion.

Next i removed the Edimax Dongle and try it with another wifi dongle (line 1140), but nothing wifi related happened. When i see the technologies from “connmanctl” i could only see ethernet.

link text

hi @jaski.tx

Hope you find something in the logs given. :slight_smile:

Are there any more logs that you require that might help you with your investigation?

hi @jy.teh

Thanks for the files. Regarding the dmesg.txt, I would need the dmesg log for your Host and not the module.

Further, our FAE ( @alvaro.tx ) for South Asia is working on this topic.

Best