Add Real Time Linux to Open Embedded image build version 2.7b4-r0

I am able to build (bitabake) a kernel image (angstrom-lxde-image) as described in the link
https://developer.toradex.com/knowledge-base/board-support-package/openembedded-(core)

I then added the PREFERRED_PROVIDER_virtual/kernel = “linux-toradex-rt” to my conf/local.conf as described in the link (Real-Time Linux)
bitabake fails with ERROR:angstrom-lxde-image-2.7b4-r0 do_rootfs()

I then removed the oe-core folder and started from scratch and tried to bitbake with the PREFERRED_PROVIDER_virtual/kernel = “linux-toradex-rt” added to my conf/local.conf i.e. a clean build.

However, the result is the same, bitbake fails with the same Error do_rootfs()

What am I missing? Is the real time not available on the 2.7b4-r0 branch? If yes, which branch do I need to go back to?

Hi

Could you attach the complete logfile with the error?

Max

link text

Please see attached. One is the terminal output and the other is the error file.

Hi

So this is the real error message:

Collected errors:
 * calculate_dependencies_for: Cannot satisfy the following dependencies for backports:
 * 	backports-kernel-module-crc-ccitt * 
 * opkg_solver_install: Cannot install package backports.

With the 2.7b4 image we added through the linux backports project newer Wi-Fi drivers to the image recipes. To do this we needed to change among other things that the crc-ccitt functionality is no longer compiled as a kernel module but this change did not make it into the RT defconfigs.

To get around the error you could do one of the following:

  • If you do not use the Wi-Fi drivers you could remove ‘backports’ from IMAGE_INSTALL, e.g. delete it in ‘meta-toradex-demos/recipes-images/images/tdx-extra.inc’ or add 'IMAGE_INSTALL_remove = “backports” ’ to local.conf.

  • Cherry-pick commit 51947d7283925979581488970a0d048a02374987
    ‘linux-toradex-rt: follow changes needed for backports’ into meta-toradex-nxp to get the needed changes to the kernel’s defconfig.

  • Add ‘CONFIG_CRC_CCITT=y’ to meta-toradex-nxp/recipes-kernel/linux/linux-toradex-rt-4.1-2.0.x/colibri-imx6/defconfig.

Max

I am not using Wi-Fi so I tried the first option and it worked!. Thanks.