Add ENV to docker

I’m using Visual Studio Code with the Torizon extension to develop a C++ application on a Verdin module. When I add an item to env, the program no longer starts, and I get image
Am I doing something wrong? Instructions on Torizon Best Practices Guide | Toradex Developer Center show exactly what I’m doing, so I’m afraid it’s a bug?

Kind regards,

Greetings @mvandenabeele,

So that we can start debugging this issue could you please provide the following information:

  • What is the exact value/property you are passing to the env configuration?
  • Are you on the stable or early access version of the extension?
  • Can this issue be reproduced easily by you? For example if you create a fresh new C++ project and add your value to env with no other changes, does this error still occur?
  • If this error is not reproducible then could you provide the config.yaml file present in your project folder. As if this is not reproducible then perhaps there some other configuration specific to your project that may be causing this.

As a final note, based off the error it seems like there’s something wrong with your launch.json file. This file should be auto-generated and typically not tampered with. Perhaps this file was accidentally modified or some other issue with it?

Best Regards,

I was trying to set ENV LD_LIBRARY_PATH=“$LD_LIBRARY_PATH:/#%application.appname%#/lib/acapela/arm-gcc-gnueabihf-10.1.0”

Just to be sure, I also changed #%application.appname%# with the application name (the value came from the internet), but with the same results. Also setting ENV ATEST=“some_value” does not work. I was not able to reproduce this behaviour. I have been trying a lot of things because this is my first real project and I have to learn a lot of new stuff.

I’m using Visual Studio Code v1.61.1 with Toradex Torizon Support extension v1.3.0. This is the config when launch is okay: config.yaml (4.0 KB)

I must say, while going trough the process to answer your questions, somehow it got fixed. I did restart everything yesterday before reporting here, but I did not open another project. So now I’m back to trying to add my application directory to LD_LIBRARY_PATH.

Hi @mvandenabeele,

is the issue resolved ?

Best Regards