Activation of audio jack on Iris + Colibri T20

Booting a freshly burnt WCE7 image v2.1-20180220 with headphones plugged into the X8 audio output jack on the Iris board with T20:

  1. While booting a starting sound can be heard for about 1-2 seconds

  2. As WCE7 completes booting, the headphone jack goes quite. None of the Windows sounds can be heard, and our application can not generate sound either.

The registry entry under “nvwavedev” remains at default values.
Under Settings/Control Panel/Volume&Sound, volume is set to max, all sounds activated.

Could you please advice on how to activate WCE sound after booting?
But also, your guidance will be much appreciate on how to remove the existing short sound during booting?

Dear @Henry,

We are not able to reproduce the issue. I have tested it on T20, WEC7, v2.1. I am able to hear clicks sounds when I change volume level in Settings/Control Panel/Volume&Sound.

How did you update the image on Tegra? Did you use layout config(ce7.cfg) file or nk_ce7.nb0 file?

Could you please program latest beta image on the module and retest again.

Please export [HKLM\Drivers\Builtin\NvWaveDev] registry using RegEdit tool and share(Use attachment feature Ctrl + U) with us.

I am looking into disabling starting sound, get back you soon.

Dear @Henry,

Please use below registry configuration to mute or enable sounds.

[HKEY_CURRENT_USER\ControlPanel\Volume]

“Mute”=dword:7 ; 7=Enable all sounds 1=Notifications,2=Apps, 4=Events.)

“Volume”=dword:99999999 ; 0=off, 0xFFFFFFFF=maximum

For more information related to volume setting, please refer Microsoft Forum.

Dear @raja.tx

See attached registry exports (both NvWaveDev and Volume). They show the values that coexist with both the starting sound during booting and the total silence after booting.

I will be experimenting with the registry values next and reporting back if there are any news.

I used the layout config to burn the v2.1 image. Will try the beta version next and also report back if I see any changes.

link text

By the way, in the default registry there is a “Control Volume” key as well as the “ControlVolume” key you suggested to edit. I don’t know whether this could be relevant.

Setting Mute to 0 silences the booting sound, but as soon as Windows is up and running no sound can be generated either.

Dear @raja.tx

We finally figured out the root of this apparently strange behaviour regarding audio.

The audio jack seems to be disabled as soon as a DVI display is connected to the Iris board. While the display takes some seconds to figure which input (VGA, HDMI or DVI) to use, the Iris board keeps the audio jack active. But as soon as the display settles on DVI mode, the jack is disabled.

How can we keep the audio jack functional while the DVI display remains plugged to the Iris board?

Solved:

Plugging a DVI display makes Windows turn off the audio jack.

The solution:

In the registry,

[HKLM\Drivers\BuiltIn\nvwavedev]
HDMIAudioOff = 1

keeps audio on the audio jack even when a DVI display is plugged in.

Dear @Henry,

Thank you for letting us know the solution.
Good Luck!